Старые версии Ubuntu не поддерживаются Canonical, это означает, что все официальные репозитории для них заморожены и не пополняются обновлениями, устраняющими проблемы с безопасностью. Категорически не рекомендуется использовать неподдерживаемые версии Ubuntu. Ubuntu поддерживает автоматический переход на новую версию без необходимости переустановки системы, поэтому рекомендуется заранее воспользоваться этой возможностью и обновить свой дистрибутив.

Вот список всех устаревших на данный момент версий Ubuntu:

Каждый релиз имеет кодовое имя и версию, основанную на годе и месяце выхода. Кодовые имена версий состоят из двух английских слов, начинающихся на одну и ту же букву. Начиная с 6.06 первые буквы слов кодового имени меняются в соответствии с латинским алфавитом.

Репозитории для неподдерживаемых версий

После окончания поддержки дистрибутива он удаляется с серверов, на которых хранятся репозитории Ubuntu. Это приводит к тому, что при попытке обновить список доступных пакетов выдаётся предупреждение о недоступности всех основных репозиториев. Однако все пакеты из репозитория на момент окончания поддержки не удаляются в никуда, а переводятся на другой сервер, поэтому если вам зачем-либо понадобится репозиторий для неподдерживаемой версии Ubuntu, вы сможете его получить. Для этого заменить все ссылки в файле /etc/apt/sources.list, отвечающие за официальные репозитории, на:

http://old-releases.ubuntu.com/ubuntu

Нет ни одной причины использовать неподдерживаемые версии Ubuntu. Архивные репозитории не обновляются и не содержат актуальных исправлений безопасности. Поэтому при окончании срока поддержки настоятельно рекомендуется обновиться до актуальной LTS-версии Ubuntu.

Статьи

Ссылки